Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 29, 2026 - 01:30 EDT
Scheduled
We are planning a platform upgrade for Monday, June 29, 2026 at 1:30AM Eastern Time Zone.
The purpose of this upgrade is to implement the latest next-generation processors in our technology stack.
The maintenance window is planned for 1 hour. During this time frame, we anticipate 15 minutes of actual downtime.
What to Expect: - You'll still be able to access JetSend and view your data as normal throughout the maintenance window. - For up to 15 minutes, any actions that save or change data will be temporarily paused — for example, sending, creating, editing, or updating records. - Any write actions attempted during this short period may need to be retried once maintenance is complete.
Posted Jun 29, 2026 - 01:30 EDT
This scheduled maintenance affected: Web Application and API Server.